Details

    • Type: Sub-task Sub-task
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: Milestone 1.3
    • Component/s: None
    • Labels:
      None

      Description

      Feed URL: http://cliqset.com/feed/atom?uid=dkleyla

      *Error"
      Caused by: javax.xml.stream.XMLStreamException: ParseError at [row,col]:[1379,264]
      Message: Invalid byte 2 of 3-byte UTF-8 sequence.
      at com.sun.xml.stream.XMLReaderImpl.next(XMLReaderImpl.java:571)
      at org.apache.abdera.parser.stax.FOMBuilder.getNextElementToParse(FOMBuilder.java:163)
      at org.apache.abdera.parser.stax.FOMBuilder.next(FOMBuilder.java:187)
      ... 71 more
      javax.xml.stream.XMLStreamException: ParseError at [row,col]:[1379,264]
      Message: Invalid byte 2 of 3-byte UTF-8 sequence.
      org.apache.abdera.parser.ParseException: javax.xml.stream.XMLStreamException: ParseError at [row,col]:[1379,264]
      Message: Invalid byte 2 of 3-byte UTF-8 sequence.
      at org.apache.abdera.parser.stax.FOMBuilder.next(FOMBuilder.java:260)
      at org.apache.axiom.om.impl.llom.OMElementImpl.getNextOMSibling(OMElementImpl.java:265)
      at org.apache.axiom.om.impl.traverse.OMChildrenQNameIterator.hasNext(OMChildrenQNameIterator.java:69)
      at org.apache.axiom.om.impl.llom.OMElementImpl.getFirstChildWithName(OMElementImpl.java:223)
      at org.apache.abdera.parser.stax.FOMElement.getTextElement(FOMElement.java:458)
      at org.apache.abdera.parser.stax.FOMElement.getText(FOMElement.java:553)
      at org.apache.abdera.parser.stax.FOMSource.getTitle(FOMSource.java:435)
      at com.sun.ceq.session.AtomFeedProcessor.processFeed(AtomFeedProcessor.java:126)
      at com.sun.ceq.session.FeedServiceImpl.updateFeed(FeedServiceImpl.java:411)
      at com.sun.ceq.session.FeedServiceImpl.timeoutHandler(FeedServiceImpl.java:388)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at com.sun.enterprise.security.application.EJBSecurityManager.runMethod(EJBSecurityManager.java:1011)
      at com.sun.enterprise.security.SecurityUtil.invoke(SecurityUtil.java:175)
      at com.sun.ejb.containers.BaseContainer.invokeTargetBeanMethod(BaseContainer.java:2920)
      at com.sun.ejb.containers.BaseContainer.callEJBTimeout(BaseContainer.java:2849)
      at com.sun.ejb.containers.EJBTimerService.deliverTimeout(EJBTimerService.java:1401)
      at com.sun.ejb.containers.EJBTimerService.access$100(EJBTimerService.java:99)
      at com.sun.ejb.containers.EJBTimerService$TaskExpiredWork.run(EJBTimerService.java:1952)
      at com.sun.ejb.containers.EJBTimerService$TaskExpiredWork.service(EJBTimerService.java:1948)
      at com.sun.ejb.containers.util.WorkAdapter.doWork(WorkAdapter.java:75)
      at com.sun.corba.ee.impl.orbutil.threadpool.ThreadPoolImpl$WorkerThread.run(ThreadPoolImpl.java:555)
      Caused by: javax.xml.stream.XMLStreamException: ParseError at [row,col]:[1379,264]
      Message: Invalid byte 2 of 3-byte UTF-8 sequence.
      at com.sun.xml.stream.XMLReaderImpl.next(XMLReaderImpl.java:571)
      at org.apache.abdera.parser.stax.FOMBuilder.getNextElementToParse(FOMBuilder.java:163)
      at org.apache.abdera.parser.stax.FOMBuilder.next(FOMBuilder.java:187)
      ... 23 more
      SELECT FEED_ID, UPDATE_INTERVAL, DEFAULT_AUTHOR_E_MAIL, FEED_URL, LAST_UPDATED, DEFAULT_TAGS, LAST_ENTRY_DATE, TITLE, CREATED_ON, ENABLED, UPDATED_ON, FEED_TYPE, APPLICATION_NAME FROM FEED WHERE (ENABLED = ?)
      bind => [true]
      javax.xml.stream.XMLStreamException: ParseError at [row,col]:[1379,264]
      Message: Invalid byte 2 of 3-byte UTF-8 sequence.
      org.apache.abdera.parser.ParseException: javax.xml.stream.XMLStreamException: ParseError at [row,col]:[1379,264]
      Message: Invalid byte 2 of 3-byte UTF-8 sequence.
      at

        Activity

        cygnusecks1 added a comment -

        Resolved in SVN revision 318 to use AbderaClient class to process stream.

        PRE added a comment -

        sees to break facebook feed

        e.g.
        Cannot process feed Peter Reisers Facebook-Meldungen: javax.xml.stream.XMLStreamException: ParseError at [row,col]:[983,1]
        Message: Premature end of file.
        org.apache.abdera.parser.ParseException: javax.xml.stream.XMLStreamException: ParseError at [row,col]:[983,1]
        Message: Premature end of file.
        at org.apache.abdera.parser.stax.FOMBuilder.next(FOMBuilder.java:260)
        at org.apache.axiom.om.impl.llom.OMNodeImpl.build(OMNodeImpl.java:318)
        at org.apache.axiom.om.impl.llom.OMElementImpl.build(OMElementImpl.java:614)
        at org.apache.abdera.parser.stax.FOMElement.complete(FOMElement.java:845)
        at org.apache.abdera.parser.stax.FOMFeed.sortEntries(FOMFeed.java:167)
        at com.sun.ceq.session.AtomFeedProcessor.processFeed(AtomFeedProcessor.java:126)
        at com.sun.ceq.session.FeedServiceImpl.updateFeed(FeedServiceImpl.java:411)
        at com.sun.ceq.session.FeedServiceImpl.updateAllFeeds(FeedServiceImpl.java:336)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:597)
        at com.sun.enterprise.security.application.EJBSecurityManager.runMethod(EJBSecurityManager.java:1011)
        at com.sun.enterprise.security.SecurityUtil.invoke(SecurityUtil.java:175)
        at com.sun.ejb.containers.BaseContainer.invokeTargetBeanMethod(BaseContainer.java:2920)
        at com.sun.ejb.containers.BaseContainer.intercept(BaseContainer.java:4011)
        at com.sun.ejb.containers.EJBLocalObjectInvocationHandler.invoke(EJBLocalObjectInvocationHandler.java:197)
        at com.sun.ejb.containers.EJBLocalObjectInvocationHandlerDelegate.invoke(EJBLocalObjectInvocationHandlerDelegate.java:83)
        at $Proxy386.updateAllFeeds(Unknown Source)
        at com.sun.ceq.webservices.jersey.FeedWebService.updateSingleFeed(FeedWebService.java:236)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:597)
        at com.sun.jersey.server.impl.model.method.dispatch.EntityParamDispatchProvider$ResponseOutInvoker._dispatch(EntityParamDispatchProvider.java:157)
        at com.sun.jersey.server.impl.model.method.dispatch.ResourceJavaMethodDispatcher.dispatch(ResourceJavaMethodDispatcher.java:67)
        at com.sun.jersey.server.impl.uri.rules.HttpMethodRule.accept(HttpMethodRule.java:154)
        at com.sun.jersey.server.impl.uri.rules.RightHandPathRule.accept(RightHandPathRule.java:111)
        at com.sun.jersey.server.impl.uri.rules.ResourceClassRule.accept(ResourceClassRule.java:71)
        at com.sun.jersey.server.impl.uri.rules.RightHandPathRule.accept(RightHandPathRule.java:111)
        at com.sun.jersey.server.impl.uri.rules.RootResourceClassesRule.accept(RootResourceClassesRule.java:63)
        at com.sun.jersey.server.impl.application.WebApplicationImpl._handleRequest(WebApplicationImpl.java:543)
        at com.sun.jersey.server.impl.application.WebApplicationImpl.handleRequest(WebApplicationImpl.java:502)
        at com.sun.jersey.server.impl.application.WebApplicationImpl.handleRequest(WebApplicationImpl.java:493)
        at com.sun.jersey.spi.container.servlet.WebComponent.service(WebComponent.java:308)
        at com.sun.jersey.spi.container.servlet.ServletContainer.service(ServletContainer.java:314)
        at com.sun.jersey.spi.container.servlet.ServletContainer.service(ServletContainer.java:239)
        at org.apache.catalina.core.ApplicationFilterChain.servletService(ApplicationFilterChain.java:427)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:333)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:214)
        at com.sun.ceq.identity.AuthenticationFilterBase.doFilter(AuthenticationFilterBase.java:139)
        at com.sun.ceq.identity.AuthenticationFilter.doFilter(AuthenticationFilter.java:112)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:246)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:214)
        at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:313)
        at org.apache.catalina.core.StandardContextValve.invokeInternal(StandardContextValve.java:287)
        at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:218)
        at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:648)
        at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:593)
        at com.sun.enterprise.web.WebPipeline.invoke(WebPipeline.java:94)
        at com.sun.enterprise.web.PESessionLockingStandardPipeline.invoke(PESessionLockingStandardPipeline.java:98)
        at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:222)
        at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:648)
        at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:593)
        at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:587)
        at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:1096)
        at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:166)
        at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:648)
        at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:593)
        at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:587)
        at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:1096)
        at org.apache.coyote.tomcat5.CoyoteAdapter.service(CoyoteAdapter.java:288)
        at com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.invokeAdapter(DefaultProcessorTask.java:647)
        at com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.doProcess(DefaultProcessorTask.java:579)
        at com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.process(DefaultProcessorTask.java:831)
        at com.sun.enterprise.web.connector.grizzly.DefaultReadTask.executeProcessorTask(DefaultReadTask.java:341)
        at com.sun.enterprise.web.connector.grizzly.DefaultReadTask.doTask(DefaultReadTask.java:263)
        at com.sun.enterprise.web.connector.grizzly.DefaultReadTask.doTask(DefaultReadTask.java:214)
        at com.sun.enterprise.web.connector.grizzly.TaskBase.run(TaskBase.java:265)
        at com.sun.enterprise.web.connector.grizzly.ssl.SSLWorkerThread.run(SSLWorkerThread.java:106)
        Caused by: javax.xml.stream.XMLStreamException: ParseError at [row,col]:[983,1]
        Message: Premature end of file.
        at com.sun.xml.stream.XMLReaderImpl.next(XMLReaderImpl.java:574)
        at org.apache.abdera.parser.stax.FOMBuilder.getNextElementToParse(FOMBuilder.java:163)
        at org.apache.abdera.parser.stax.FOMBuilder.next(FOMBuilder.java:187)
        ... 69 more
        SELECT PERSON_ID,

        cygnusecks1 added a comment -

        This bug is caused by a bug in Abdera which I have now filed: https://issues.apache.org/jira/browse/ABDERA-249

        As a workaround, I changed the code to force the stream to not be GZIP-compressed. Committed this in SVN revision 322.

        PRE added a comment -

        closed all ticket for Milestone Release 1.3


          People

          • Assignee:
            cygnusecks1
            Reporter:
            PRE
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: