Issue Details (XML | Word | Printable)

Key: COMMUNITY_EQUITY-417
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: DmitryRyashchentsev
Reporter: PRE
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
community-equity

getting UNKOWN activties with Offline sync

Created: 11/Jan/10 04:12 PM   Updated: 15/Feb/10 10:33 AM   Resolved: 21/Jan/10 05:03 PM
Component/s: CeQ math
Affects Version/s: None
Fix Version/s: Milestone 1.3

Time Tracking:
Not Specified

File Attachments: 1. HTML File resultset.html (430 kB) 12/Jan/10 10:43 PM - PRE

Issue Links:
Blocker
 

Tags:


 Description  « Hide

Every Information object has UNKNOWN activities from various authors

e.g.
[153] UNKNOWN about 3 days ago by Victor Chiu
[153] UNKNOWN about 3 days ago by David Epps
[153] UNKNOWN about 3 days ago by Alain Geenrits
[153] UNKNOWN about 3 days ago by Christian Bandulet
[153] UNKNOWN about 3 days ago by Wanita Mackinnon
[153] UNKNOWN about 3 days ago by Alain Geenrits
[153] UNKNOWN about 3 days ago by Christian Bandulet
[..

How to produce it ?

  1. import a feed
  2. go to listing widget
  3. click on (e) of an information to show the activties


DmitryRyashchentsev added a comment - 11/Jan/10 05:49 PM

What do you see in admin history panel?


PRE added a comment - 11/Jan/10 05:57 PM

Please load a feed and check out the activity log.
As far Is I can remember ist shows unknown activity's but since we don't have a filter on activity's type - I can't find it with the activity admin ...


PRE added a comment - 12/Jan/10 10:43 PM

please check Action table data
strange entries e.g
1. action with data
2. then a few records with strange data


PRE added a comment - 12/Jan/10 10:47 PM - edited

Could this relate to the typo I corrected e.g.

Project: community-equity
Repository: svn
Revision: 458
Author: PRE
Date: 2010-01-08 05:19:40 UTC
Link:

Log Message:
------------
Corrected typo in action type

Revisions:
----------
458

Modified Paths:
---------------
trunk/ceq-ejb/schema/mysql_5.sql

Diffs:
------
Index: trunk/ceq-ejb/schema/mysql_5.sql
===================================================================
— trunk/ceq-ejb/schema/mysql_5.sql (revision 457)
+++ trunk/ceq-ejb/schema/mysql_5.sql (revision 458)
@@ -676,7 +676,7 @@
INSERT INTO ACTION_TYPE( ACTION_TYPE_ID, ACTION_TYPE_TITLE ) VALUES ( 11, 'Main Author changed' );
INSERT INTO ACTION_TYPE( ACTION_TYPE_ID, ACTION_TYPE_TITLE ) VALUES ( 12, 'Cloned' );
INSERT INTO ACTION_TYPE( ACTION_TYPE_ID, ACTION_TYPE_TITLE ) VALUES ( 13, 'Deleted' );

-INSERT INTO ACTION_TYPE( ACTION_TYPE_ID, ACTION_TYPE_TITLE ) VALUES ( 14, 'TadAdded' );
+INSERT INTO ACTION_TYPE( ACTION_TYPE_ID, ACTION_TYPE_TITLE ) VALUES ( 14, 'TagAdded' );

INSERT INTO ACTION_TYPE( ACTION_TYPE_ID, ACTION_TYPE_TITLE ) VALUES ( 15, 'TagDeleted' );


PRE added a comment - 12/Jan/10 11:42 PM

5495 Wed Jan 13 00:29:16 2010 ? TagAdded undefined dlnprasad 0 - 0 - deleted ? 0
5494 Wed Jan 13 00:29:16 2010 ? TagAdded undefined williamxue 0 - 0 - deleted ? 0
5493 Wed Jan 13 00:29:16 2010 ? TagAdded Brian Hiatt 0 - 0 - deleted ? 0
5492 Wed Jan 13 00:29:16 2010 ? TagAdded undefined nico 0 - 0 - deleted ? 0

from the activity admin


DmitryRyashchentsev added a comment - 14/Jan/10 06:36 PM

Added TagAdded and TagDeleted evenst to InformationAction.

Peter,
I could not test it well, can you please test it as like.

We still have a related an open issue COMMUNITY_EQUITY-276 that is a reason of random authors are types instead of corrct ones.
The fix of COMMUNITY_EQUITY-276 will fix this problem.


PRE added a comment - 14/Jan/10 08:57 PM

I tested the latest version - see results below

+ no UNKOWN action anymore - the are all mapped to ACTION_TAG_ADDED

  • but system still adds TAG events to all informations even if they don't have tags
  • the tag event is bound to different users (I guess these are the user before or after the event is calculated)
  • I also was running aging process and it does not run trough anymore (10'000+ objects)
  • I get deadlocks (see below)
  • maybe we have to stop the offline calculation and feed import during aging

[#|2010-01-14T21:45:53.218+0100|FINE|sun-appserver2.1|oracle.toplink.essentials.session.file:/Users/Peter/NetBeansProjects/community-equity~svn/trunk/ceq/dist/gfdeploy/ceq-ejb_jar/-ceq.sql|_ThreadID=1143;_ThreadName=p: thread-pool-1; w: 1042;ClassName=null;MethodName=null;_RequestID=3009d5d4-3fe3-4ae5-b1be-65a592081f82;|SELECT ACTION_LOG_ID FROM ACTION_DATA WHERE (ACTION_LOG_ID = ?)
bind => [48729]|#]

[#|2010-01-14T21:45:53.243+0100|INFO|sun-appserver2.1|javax.enterprise.system.container.ejb|_ThreadID=1143;_ThreadName=p: thread-pool-1; w: 1042;DataManipulatorImpl;|EJB5018: An exception was thrown during an ejb invocation on [DataManipulatorImpl]|#]

[#|2010-01-14T21:45:53.243+0100|INFO|sun-appserver2.1|javax.enterprise.system.container.ejb|_ThreadID=1143;_ThreadName=p: thread-pool-1; w: 1042;|
javax.ejb.TransactionRolledbackLocalException: Exception thrown from bean; nested exception is: javax.persistence.EntityExistsException:
Exception Description: Cannot persist detached object [com.sun.ceq.entity.math.ActionData@283ef378].
Class> com.sun.ceq.entity.math.ActionData Primary Key> [48729]
javax.persistence.EntityExistsException:
Exception Description: Cannot persist detached object [com.sun.ceq.entity.math.ActionData@283ef378].
Class> com.sun.ceq.entity.math.ActionData Primary Key> [48729]
at oracle.toplink.essentials.internal.ejb.cmp3.base.EntityManagerImpl.persist(EntityManagerImpl.java:224)
at com.sun.enterprise.util.EntityManagerWrapper.persist(EntityManagerWrapper.java:238)
at com.sun.ceq.math.model.LinearModelImpl.processAction(LinearModelImpl.java:480)
AND

Caused by: javax.ejb.TransactionRolledbackLocalException: Exception thrown from bean; nested exception is: Exception [TOPLINK-4002] (Oracle TopLink Essentials - 2.1 (Build b60e-fcs (12/23/2008))): oracle.toplink.essentials.exceptions.DatabaseException
Internal Exception: java.sql.SQLException: Lock wait timeout exceeded; try restarting transaction
Error Code: 1205
Call: UPDATE INFORMATION_CEQ SET INFORMATION_IQB = (INFORMATION_IQB + ?), INFORMATION_IQ = (INFORMATION_IQ + ?), INFORMATION_IQK = (INFORMATION_IQK + ?) WHERE (INFORMATION_ID = ?)
bind => [7740, 1.0, 6, 5012]
Query: UpdateAllQuery()
at com.sun.ejb.containers.BaseContainer.checkExceptionClientTx(BaseContainer.java:3753)
at com.sun.ejb.containers.BaseContainer.postInvokeTx(BaseContainer.java:3601)
at com.sun.ejb.containers.BaseContainer.postInvoke(BaseContainer.java:1379)
... 20 more

#]

[#|2010-01-14T21:51:16.455+0100|INFO|sun-appserver2.1|javax.enterprise.system.stream.out|_ThreadID=1138;_ThreadName=p: thread-pool-1; w: 1037;|
consume: Ok 174554|#]

[#|2010-01-14T21:51:16.455+0100|INFO|sun-appserver2.1|javax.enterprise.system.stream.out|_ThreadID=1138;_ThreadName=p: thread-pool-1; w: 1037;|
consume: log=48950 action=7 info=185 person/tag=123 date=1263501903448|#]

[#|2010-01-14T21:51:16.455+0100|INFO|sun-appserver2.1|javax.enterprise.system.container.ejb|_ThreadID=1138;_ThreadName=p: thread-pool-1; w: 1037;DataManipulatorImpl;|EJB5018: An exception was thrown during an ejb invocation on [DataManipulatorImpl]|#]

[#|2010-01-14T21:51:16.455+0100|INFO|sun-appserver2.1|javax.enterprise.system.container.ejb|_ThreadID=1138;_ThreadName=p: thread-pool-1; w: 1037;|
javax.ejb.TransactionRolledbackLocalException: Client's transaction aborted
at com.sun.ejb.containers.BaseContainer.useClientTx(BaseContainer.java:3419)
at com.sun.ejb.containers.BaseContainer.preInvokeTx(BaseContainer.java:3299)
at com.sun.ejb.containers.BaseContainer.preInvoke(BaseContainer.java:1244)
at com.sun.ejb.containers.EJBLocalObjectInvocationHandler.invoke(EJBLocalObjectInvocationHandler.java:195)
at com.sun.ejb.containers.EJBLocalObjectInvocationHandlerDelegate.invoke(EJBLocalObjectInvocationHandlerDelegate.java:83)
at $Proxy234.processAction(Unknown Source)
at com.sun.ceq.math.model.DataManipulatorMessageConsumerBean.processMessage(DataManipulatorMessageConsumerBean.java:134)
at com.sun.ceq.math.model.DataManipulatorMessageConsumerBean.onMessage(DataManipulatorMessageConsumerBean.java:91)
at sun.reflect.GeneratedMethodAccessor686.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at com.sun.enterprise.security.application.EJBSecurityManager.runMethod(EJBSecurityManager.java:1011)
at com.sun.enterprise.security.SecurityUtil.invoke(SecurityUtil.java:175)
at com.sun.ejb.containers.BaseContainer.invokeTargetBeanMethod(BaseContainer.java:2920)
at com.sun.ejb.containers.BaseContainer.intercept(BaseContainer.java:4011)
at com.sun.ejb.containers.MessageBeanContainer.deliverMessage(MessageBeanContainer.java:1111)
at com.sun.ejb.containers.MessageBeanListenerImpl.deliverMessage(MessageBeanListenerImpl.java:74)
at com.sun.enterprise.connectors.inflow.MessageEndpointInvocationHandler.invoke(MessageEndpointInvocationHandler.java:179)
at $Proxy255.onMessage(Unknown Source)
at com.sun.messaging.jms.ra.OnMessageRunner.run(OnMessageRunner.java:258)
at com.sun.enterprise.connectors.work.OneWork.doWork(OneWork.java:76)
at com.sun.corba.ee.impl.orbutil.threadpool.ThreadPoolImpl$WorkerThread.run(ThreadPoolImpl.java:555)
Begin forwarded message:


DmitryRyashchentsev added a comment - 17/Jan/10 10:30 PM

PR> but system still adds TAG events to all informations even if they don't have tags
Fixed, at least found that INFORMATION_VIEWED generated INFORMATION_TAGGED

PR> the tag event is bound to different users (I guess these are the user before or after the event is calculated)
Fixed by COMMUNITY_EQUITY-276 fix

PR> I also was running aging process and it does not run trough anymore (10'000+ objects)
Fixed by moving aging to async part

PR> I get deadlocks (see below)
Fixed by COMMUNITY_EQUITY-420 fix

PR> maybe we have to stop the offline calculation and feed import during aging
With COMMUNITY_EQUITY-420 that should work

I still can see some JMS errors effects, so some exection are still in the log


DmitryRyashchentsev added a comment - 21/Jan/10 05:03 PM

Move to RESOLVED state as it works now.