Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: Milestone 1.3
    • Fix Version/s: Milestone 1.3
    • Component/s: CeQ math
    • Labels:
      None

      Description

      It seems that CeQ math calculates TagEquity doubled

      Example:
      1. import wikiepedia feed with application type "test wiki" http://en.wikipedia.org/w/index.php?title=Special:RecentChanges&feed=atom
      2. after import of 1550 entry the tag equitysource:test wiki is (15'500)
      4. a create wiki action is 5 points - hence TQ should be 1550*5 = 7750

        Activity

        PRE added a comment -

        Also so doubled/multiple entries in the Information Table
        e.g.
        Full Texts INFORMATION_ID INFORMATION_KEY ARCHIVED TITLE URL Ascending DESCRIPTION APPLICATION_NAME INFORMATION_TYPE_ID PARENT_INFORMATION_ID MAIN_AUTHOR_ID RATING RATING_COUNT VIEW_COUNT DOWNLOAD_COUNT CREATED_ON UPDATED_ON UPDATED_BY
        Edit Delete 7028 https://sunspace.sfbay.sun.com/pages/viewpage.acti... TASK ASSIGNED TO AM-US-CAS https://sunspace.sfbay.sun.com/pages/viewpage.acti... TASK ASSIGNED TO AM-US-CAS SunWiki 1 NULL 85 0 0 0 0 2010-01-28 16:11:52 2010-01-28 16:11:52 NULL
        Edit Delete 7029 https://sunspace.sfbay.sun.com/pages/viewpage.acti... TASK ASSIGNED TO AM-US-CAS https://sunspace.sfbay.sun.com/pages/viewpage.acti...

        DmitryRyashchentsev added a comment -

        As I can see that is "effect" of async calculations.
        The problem is:
        In sync mode we have the following sequence of actions:
        1. info action
        2. update CEQ for the info action with current info tags set
        3. add tag
        4. update CEQ with the new tag

        In async mode we have:
        1. info action
        2. add tag
        3. update CEQ for the info action with current info tags set, including the added tag
        4. update CEQ with the new tag, counting it 2nd time as we use incremental calculation model

        The general problem is current data model (provided by InformationService, PersonService, TagService etc) can not be used in async part more. We need to store a separate copy of all necessary for CEQ math data.

        DmitryRyashchentsev added a comment -

        Added relation Information-Tag to "async" part - table INFO_TAG_CEQ, so TQ is calculated correctly.

        PRE added a comment -

        did some preliminary testing and calculation of tag equity looks good !

        PRE added a comment -

        closed all ticket for Milestone Release 1.3


          People

          • Assignee:
            DmitryRyashchentsev
            Reporter:
            PRE
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: