Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 1.0-Beta
    • Fix Version/s: 1.1
    • Component/s: None
    • Labels:
      None
    • Environment:

      OS: Ubuntu
      IDE: Netbeans 7.1.1
      Redmine 1.4.1
      Git plugin

      Description

      In NetBeans, in the services tab i am able to see the Issue Trackers option. I am also able to create the connection with the redmine project and search and find the issues created but the error appears when i try to open an issue. This error happens when i click on the issue grid or when i put the issue number and click "Go to Issue". The same issue appears when i try to commit something using git plugin. I am able to select the issue but after clicking in the commit button, the error appears.

      Here is the IDE Log:

      SEVERE [com.kenai.redmineNB.Redmine]: Can't get Redmine Issue Trackers
      org.redmine.ta.NotFoundException: Server returned '404 not found'. response body:<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
      "http://www.w3.org/TR/html4/loose.dtd">
      <html>
      <title>redMine 404 error</title>
      <style>
      body{
      font-family: Trebuchet MS,Georgia,"Times New Roman",serif;
      color:#303030;
      margin:10px;
      }
      h1{
      font-size:1.5em;
      }
      p{
      font-size:0.8em;
      }
      </style>
      <body>
      <h1>Page not found</h1>
      <p>The page you were trying to access doesn't exist or has been removed.</p>
      <p><a href="javascript:history.back()">Back</a></p>
      </body>
      </html>
      at org.redmine.ta.internal.Communicator.sendRequest(Communicator.java:64)
      at org.redmine.ta.RedmineManager.getObjectsListV11(RedmineManager.java:401)
      at org.redmine.ta.RedmineManager.getObjectsList(RedmineManager.java:370)
      at org.redmine.ta.RedmineManager.getTrackers(RedmineManager.java:888)
      [catch] at com.kenai.redmineNB.repository.RedmineRepository.getTrackers(RedmineRepository.java:245)
      at com.kenai.redmineNB.issue.RedmineIssuePanel.initValues(RedmineIssuePanel.java:361)
      at com.kenai.redmineNB.issue.RedmineIssuePanel.<init>(RedmineIssuePanel.java:47)
      at com.kenai.redmineNB.issue.RedmineIssueController.getComponent(RedmineIssueController.java:30)
      at org.netbeans.modules.bugtracking.ui.issue.IssueTopComponent.setIssue(IssueTopComponent.java:209)
      at org.netbeans.modules.bugtracking.ui.issue.IssueTopComponent.find(IssueTopComponent.java:468)
      at org.netbeans.modules.bugtracking.ui.issue.IssueTopComponent.find(IssueTopComponent.java:447)
      at org.netbeans.modules.bugtracking.ui.issue.IssueAction$1.run(IssueAction.java:97)
      at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
      at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:641)
      at java.awt.EventQueue.access$000(EventQueue.java:84)
      at java.awt.EventQueue$1.run(EventQueue.java:602)
      at java.awt.EventQueue$1.run(EventQueue.java:600)
      at java.security.AccessController.doPrivileged(Native Method)
      at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:87)
      at java.awt.EventQueue.dispatchEvent(EventQueue.java:611)
      at org.netbeans.core.TimableEventQueue.dispatchEvent(TimableEventQueue.java:162)
      at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
      at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
      at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)
      at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
      at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
      at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)
      SEVERE [com.kenai.redmineNB.Redmine]: Can't get Issue Categories for Redmine Project Newsletter
      org.redmine.ta.NotFoundException: Server returned '404 not found'. response body:<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
      "http://www.w3.org/TR/html4/loose.dtd">
      <html>
      <title>redMine 404 error</title>
      <style>
      body{
      font-family: Trebuchet MS,Georgia,"Times New Roman",serif;
      color:#303030;
      margin:10px;
      }
      h1{
      font-size:1.5em;
      }
      p{
      font-size:0.8em;
      }
      </style>
      <body>
      <h1>Page not found</h1>
      <p>The page you were trying to access doesn't exist or has been removed.</p>
      <p><a href="javascript:history.back()">Back</a></p>
      </body>
      </html>
      at org.redmine.ta.internal.Communicator.sendRequest(Communicator.java:64)
      at org.redmine.ta.RedmineManager.getCategories(RedmineManager.java:838)
      [catch] at com.kenai.redmineNB.repository.RedmineRepository.getIssueCategories(RedmineRepository.java:311)
      at com.kenai.redmineNB.issue.RedmineIssuePanel.initValues(RedmineIssuePanel.java:374)
      at com.kenai.redmineNB.issue.RedmineIssuePanel.<init>(RedmineIssuePanel.java:47)
      at com.kenai.redmineNB.issue.RedmineIssueController.getComponent(RedmineIssueController.java:30)
      at org.netbeans.modules.bugtracking.ui.issue.IssueTopComponent.setIssue(IssueTopComponent.java:209)
      at org.netbeans.modules.bugtracking.ui.issue.IssueTopComponent.find(IssueTopComponent.java:468)
      at org.netbeans.modules.bugtracking.ui.issue.IssueTopComponent.find(IssueTopComponent.java:447)
      at org.netbeans.modules.bugtracking.ui.issue.IssueAction$1.run(IssueAction.java:97)
      at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
      at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:641)
      at java.awt.EventQueue.access$000(EventQueue.java:84)
      at java.awt.EventQueue$1.run(EventQueue.java:602)
      at java.awt.EventQueue$1.run(EventQueue.java:600)
      at java.security.AccessController.doPrivileged(Native Method)
      at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:87)
      at java.awt.EventQueue.dispatchEvent(EventQueue.java:611)
      at org.netbeans.core.TimableEventQueue.dispatchEvent(TimableEventQueue.java:162)
      at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
      at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
      at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)
      at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
      at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
      at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)
      SEVERE [global]
      java.lang.RuntimeException: RedmineXMLParser: can't parse the response. This is not a valid XML:
      <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
      "http://www.w3.org/TR/html4/loose.dtd">
      <html>
      <title>redMine 500 error</title>
      <style>
      body{
      font-family: Trebuchet MS,Georgia,"Times New Roman",serif;
      color:#303030;
      margin:10px;
      }
      h1{
      font-size:1.5em;
      }
      p{
      font-size:0.8em;
      }
      </style>
      <body>
      <h1>Internal error</h1>
      <p>An error occurred on the page you were trying to access.<br />
      If you continue to experience problems please contact your redMine administrator for assistanc...
      at org.redmine.ta.internal.RedmineXMLParser.verifyStartsAsXML(RedmineXMLParser.java:157)
      at org.redmine.ta.internal.RedmineXMLParser.parseObjectsFromXML(RedmineXMLParser.java:166)
      at org.redmine.ta.internal.RedmineXMLParser.parseVersionsFromXML(RedmineXMLParser.java:260)
      at org.redmine.ta.RedmineManager.getVersions(RedmineManager.java:813)
      at com.kenai.redmineNB.repository.RedmineRepository.getVersions(RedmineRepository.java:345)
      at com.kenai.redmineNB.issue.RedmineIssuePanel.initValues(RedmineIssuePanel.java:378)
      at com.kenai.redmineNB.issue.RedmineIssuePanel.<init>(RedmineIssuePanel.java:47)
      at com.kenai.redmineNB.issue.RedmineIssueController.getComponent(RedmineIssueController.java:30)
      at org.netbeans.modules.bugtracking.ui.issue.IssueTopComponent.setIssue(IssueTopComponent.java:209)
      at org.netbeans.modules.bugtracking.ui.issue.IssueTopComponent.find(IssueTopComponent.java:468)
      at org.netbeans.modules.bugtracking.ui.issue.IssueTopComponent.find(IssueTopComponent.java:447)
      at org.netbeans.modules.bugtracking.ui.issue.IssueAction$1.run(IssueAction.java:97)
      at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
      at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:641)
      at java.awt.EventQueue.access$000(EventQueue.java:84)
      at java.awt.EventQueue$1.run(EventQueue.java:602)
      at java.awt.EventQueue$1.run(EventQueue.java:600)
      at java.security.AccessController.doPrivileged(Native Method)
      at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:87)
      at java.awt.EventQueue.dispatchEvent(EventQueue.java:611)
      at org.netbeans.core.TimableEventQueue.dispatchEvent(TimableEventQueue.java:162)
      at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
      at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
      at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)
      at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
      at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
      [catch] at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)

      Thanks for taking care of it!!

      Marcelo

        Activity

        Anchialas added a comment -

        This seems to be not an issue of RedmineNB. The RESTful web services for getting Trackers and Issue Categories cannot be found. Unfortunately the requested URL isn't reported in the exception. More information about the Redmine Rest API and the sub url's see http://www.redmine.org/projects/redmine/wiki/Rest_api

        Do you have a special Redmine setup (e.g. custom routings)? Or it is a network issue...?

        mkrivan added a comment -

        I have the same issue using Redmine 2.5.3 and the newest redmineNB plugin (even if I have compiled the master project - version 1.6-SNAPSHOT). I am using redmine with sub-uri /redmine. All of the other functionality is working with redmineNB just this error message rising and annyoying.

        Perhaps there is something with the issue categories API itself because /redmine/projects/1/issues.json?key=... working fine but /redmine/projects/1/issue_categories?key=... gives Page not found.

        But in wich layer this URL called? I would like to identify but I do not where can I start. Thanx for your help.

        mkrivan added a comment -

        Of course there was .json in the URL as well:
        /redmine/projects/1/issue_categories.json?key=


          People

          • Assignee:
            Anchialas
            Reporter:
            maberastain
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: