Last updated May 26, 2010 10:28, by Jaroslav Bachorik
Feedicon  

NetBeans IDE Integration

Compatibility

You need NetBeans 6.9 to install the integration. Sorry, no support for the older versions.

Where to get it from

Features

  • A pre-configured shared library called BTrace - you can use it in any java project to get access to BTrace client apis
  • A pre-configured template project (Script Library) - a convenience template containing the reference to the previously mentioned library
  • Error highlighting taking into account the BTrace additional validation rules
(Fig.1)Script validation
  • Code completion, syntax coloring etc. (the full feature pack of what the IDE provides for java files)
  • Simplified script execution - you can start and stop the script directly from the toolbar associated with the edited script
(Fig.2)Application selector


(Fig.3)Deploy button
  • Mysql
  • Glassfish
  • Jruby
  • Rails
  • Nblogo
Terms of Use; Privacy Policy;
© 2014, Oracle Corporation and/or its affiliates
(revision 20160708.bf2ac18)
 
 
Close
loading
Please Confirm
Close