Can't resolve errors

  31 posts   Feedicon  
Replies: 30 - Last Post: December 11, 2009 08:10
by: divemaster
showing 1 - 20 of 31
« Previous 1
 
Posted: December 12, 2008 18:21 by kolotyluk
I installed the plugin in my Eclipse 3.4 under Windows and followed the tutorial. After creating the first Stage the IDE complains about the following errors.

package com.sun.eclipse.example; // line 1

/**
* @author eric
*/
javafx.stage.Stage { // line 6
title : "HelloWorld"
scene: javafx.scene.Scene {
width: 200
height: 200
content: [ ]
}
}

Line 1 - Cannot access java.lang.Object class file for java.lang.Object not found
Line 7 - Invalid assignment
Line 8 - Invalid assignment
Line 9 - Invalid assignment
Line 10 - Invalid assignment
Line 11- Invalid assignment
Line 8 - Package javafx.scene does not exist
Line 6 - Package javafx.stage does not exist

I’ve checked my build path and both Java 6 and JavaFX 1.0 are on it, and I can’t see anything else obviously wrong.

Any help would be appreciated

Cheers, Eric

 
Posted: December 13, 2008 15:43 by optipus
Hi,

I had the same problem. In my case I had installed the javafx sdk preview instead of the javafx sdk...

WHL
 
Posted: January 05, 2009 16:52 by David Kaspar
Hi,

I am not sure but it seems that you do not have classes/jars files from JavaFX SDK on the classpath of your project. Could you check whether in the:
Main Menu | Window | Preferences | Java | Build Path | Classpath Variables
panel you have JAVAFX_HOME variable set to the root directory where you have installed your JavaFX SDK 1.0 or later.
Please, check also in the:
your-project node | Popup Menu | Preferences | Java Build Path | Libraries
panel, that you have "JavaFX System Library" item listed. Double-click on it and a new dialog should say:
1) JavaFX SDK is detected
2) Desktop profile is selected
If all above settings are set correctly, then it should work immediately.

Regards,
David
 
Posted: January 10, 2009 23:54 by kolotyluk
The JAVAFX_HOME variable is set correctly.

When I double-click the JavaFX System Library a dialog comes up and says JavaFX SDK is detected and the Desktop profile is selected.

Cheers, Eric
 
Posted: January 24, 2009 20:10 by kolotyluk
OK, for whatever reason, while the IDE shows compilation errors, now when I run the program it compiles fine and actually runs correctly. I don't really know what I did to change this, it just started working one day.

I'm going to try Eclipse 3.4.1 and JDK 5u17 next...

Cheers, Eric
 
Posted: January 25, 2009 04:40 by kolotyluk
And now it doesn't run any more Frown

I don't know what I did, but now I get


executing commandline: [C:\Program Files\JavaFX\javafx-sdk1.0\bin\..\bin\javafxc.exe, -profile, desktop, -target, 1.5, -g, -classpath, ;D:\Documents and Settings\eric\My Documents\eclipse\workspace\MyJavaFXProject\temp\compiled, -d, D:\Documents and Settings\eric\My Documents\eclipse\workspace\MyJavaFXProject\temp\compiled, @D:\Documents and Settings\eric\My Documents\eclipse\workspace\MyJavaFXProject\temp\javafxc345496681460166983sources]
D:\Documents and Settings\eric\My Documents\eclipse\workspace\MyJavaFXProject\src\com\sun\eclipse\example\Main.fx:12: cannot find symbol
symbol : class Scene
location: package javafx.stage
scene: javafx.stage.Scene {
 
Posted: December 16, 2008 17:17 by Martin Ryzl
does it mean this topic can be considered closed?
 
Posted: December 16, 2008 19:26 by kolotyluk
No, this topic is not solved - I installed the Java FX 1.0 SDK, not the preview.

I still can't get rid of the errors the compiler is giving me.

Help would still be appreciated.

Cheers, Eric
 
Posted: December 16, 2008 21:26 by stemkev
Hi Eric,

I sometimes see the error you're seeing, not being able to find java.lang.Object, even with normal Java projects.

For me, it always goes away if I remove the JRE system library from the build path and then add it back in again.

Cheers,
Kevin
 
Posted: December 17, 2008 01:06 by kolotyluk
OK, I tried removing the JRE from the classpath and adding it again.

No change, still the same set of errors.

Cheers, Eric
 
Posted: December 27, 2008 21:18 by Xhelas
Same for me. Even after reinstalling a freshly download eclipse 3.4 for windows XP, the plugin does no work correctly. The java perspective exists but incons inside are not valid. Creating the sample fx scipt leads to several classpath like errors. More over, trying to launch the script freezes eclipse. It has to be killed by the process manager. Changing the installation path of javafx does not change anything.
My config is eclipse 3.4 jee ganymede SR1, javafx sdk 1 0 1 , java 1.6u11

You can ask more details if it helps.

Regards

Alexandre
 
Posted: January 08, 2009 10:55 by gvisoc
Exactly the same is happening to me. I've tried every workaround posted here, but I cannot make it work.

I have both Ganymede and javafx-sdk 1.0.1 and jre 1.6u11.
 
Posted: January 08, 2009 16:39 by David Kaspar
I am not sure whether it would help but JavaFX SDK requires JDK (not JRE) to compile your sources...
Could you send me an console output of the "javafxpackager" process? It is usually hidden behind "javafx application execution" console output...
Thanks, D.
 
Posted: January 10, 2009 23:32 by kolotyluk
I've confirmed I've got JavaFX SDK 1.0 installed, as well as Java JDK 1.6.0_11.

OK, the strangest thing now. I can actually run the example application. I can change the source and run it again, it runs fine and show the changes.

However, the IDE still show all kinds of errors, as I mention before (the same errors).

Is this the console output you were talking about...

using profile: DESKTOP
Java compilation
nothing to compile
JavaFX compilation
executing commandline: [C:\Program Files\JavaFX\javafx-sdk1.0\bin\..\bin\javafxc.exe, -profile, desktop, -target, 1.5, -g, -classpath, ;D:\Documents and Settings\eric\My Documents\eclipse\workspace\MyJavaFXProject\temp\compiled, -d, D:\Documents and Settings\eric\My Documents\eclipse\workspace\MyJavaFXProject\temp\compiled, @D:\Documents and Settings\eric\My Documents\eclipse\workspace\MyJavaFXProject\temp\javafxc8411623045508485812sources]
copying: D:\Documents and Settings\eric\My Documents\eclipse\workspace\MyJavaFXProject\src into: D:\Documents and Settings\eric\My Documents\eclipse\workspace\MyJavaFXProject\temp\compiled using filter: RESOURCES
copying: D:\Documents and Settings\eric\My Documents\eclipse\workspace\MyJavaFXProject\src\com into: D:\Documents and Settings\eric\My Documents\eclipse\workspace\MyJavaFXProject\temp\compiled\com using filter: RESOURCES
copying: D:\Documents and Settings\eric\My Documents\eclipse\workspace\MyJavaFXProject\src\com\sun into: D:\Documents and Settings\eric\My Documents\eclipse\workspace\MyJavaFXProject\temp\compiled\com\sun using filter: RESOURCES
copying: D:\Documents and Settings\eric\My Documents\eclipse\workspace\MyJavaFXProject\src\com\sun\eclipse into: D:\Documents and Settings\eric\My Documents\eclipse\workspace\MyJavaFXProject\temp\compiled\com\sun\eclipse using filter: RESOURCES
copying: D:\Documents and Settings\eric\My Documents\eclipse\workspace\MyJavaFXProject\src\com\sun\eclipse\example into: D:\Documents and Settings\eric\My Documents\eclipse\workspace\MyJavaFXProject\temp\compiled\com\sun\eclipse\example using filter: RESOURCES
copying runtime libraris
application Jar packaging
generating JNLP launcher
generating JNLP launcher
generating HTML applet page

There are clearly no error in the source as the program runs fine. Something is broken in the IDE. I hope we can find a way to fix it.

Cheers, Eric
 
Posted: January 11, 2009 20:29 by dstrupl
Hello,

this is a desperate attempt but nevertheless can you try to use the latest JDK 1.5.x? I know it should work on 1.6.0_x but still worth trying IMHO. Also if I remember correctly all our experiments were done using Eclipse 3.4.1 - am I correct David?

Br,

David Strupl
 
Posted: January 24, 2009 21:20 by kolotyluk
OK, so I installed Eclipse 3.4.1 - no luck, same problem.

Next I installed Java 5u17, I ran Eclipse 3.4.1 with that run-time, and switched to the 1.5.0 jre on my classpath - still no luck, exactly the same problem.

So, is there any hope that there will ever be a Java FX plug-in for Eclipse that is robust enough to "just work?"

Cheers, Eric
 
Posted: January 12, 2009 09:45 by asif_zzz
Hi,
Im also get the same set of error's which Eric got.
Im using Eclipse 3.4,java verison 1.6.0_11,javafx sdk 1.0.

Regards
Aashik

 
Posted: January 21, 2009 16:13 by Bonsai
Hi
I've got the same ERROR.

When I build the programm if got Errors that it can't find imported JARs. But when I try to run the programm it works fine.
I'm using Eclipse 3.4.1, JDK 1.6.0_07 (i also tryed 1.5.0_04) and javafx-sdk1.0.

And the code completion dosn't work.

Thanks for informations
 
Posted: January 24, 2009 21:21 by kwadruppel
same error here with eclipse 3.4.1 M20080911-1700 (eclipse-jee-ganymede-SR1-win32)
and javafx-1.0.1, Build-ID: 2008-12-11_23-30-43

without success i've tried:
- jdk1.6.0_11 with -vm option to start eclipse.
- jdk1.5.0_17 in eclipse/jre folder (no -vm).
- remove + added JRE System Library to the project build path.
- tried to remove + add the JavaFX System Library to the project build path, but it won't let me. I can remove it, and when adding it back i can select it from the list, but it won't stick. I guess this could be another minor bug, or a symptom to the problem? Note that the JavaFX nature can't be restored either.

- funnily enough, adding just an import to the topic-start example, eg import javafx.scene.text.Text, the error changes to:
"cannot access javafx.lang.Builtins class file for javafx.lang.Builtins not found"
The code does run however. Even code using javafx.scene.text.Text but without the import (i'm new to JavaFX, maybe that's supposed to work?).

Any suggestions, perhaps on other JDK/eclipse/plugin versions?

 
Posted: February 01, 2009 18:28 by Cardoso
I just installed com.sun.javafx.eclipse.feature-win32-win32-x86-1.0.1.zip in my Eclipse 3.3.2 and I'm having the same problem described here.

I also can run the code without a problem but in compile time eclipse tells me the code has several errors.

Anyone found a resolution for this yet?
showing 1 - 20 of 31
« Previous 1
Replies: 30 - Last Post: December 11, 2009 08:10
by: divemaster
  • Mysql
  • Glassfish
  • Jruby
  • Rails
  • Nblogo
Terms of Use; Privacy Policy;
© 2013, Oracle Corporation and/or its affiliates
(revision 20140418.2d69abc)
 
 
Close
loading
Please Confirm
Close